Matrixformel zur Addition / Summierung jeden 2. Wertes
bei  www. finitmat .de

Wie addiert / summiert man jeden zweiten Wert einer Spalte oder einer Zeile in EXCEL 2000?

Hierzu könnte man jeweils eine Matrix-Formel verwenden.

Eine Matrixformel ist ein Schmankerl von EXCEL, welches die Durchführung mehrer Rechenoperationen mittels einer Anweisung ermöglicht.

Wie erstellt man eine Matrixformel?

Man erstellt eine Matrixformel auf dieselbe Art und Weise wie andere Formeln, mit dem Unterschied, dass die Formeleingabe mit der Tastenkombination STRG+UMSCHALT+EINGABE abgeschlossen wird!

Welche Matrixformel könnte für die Berechnung jedes zweiten Wertes eines Spaltenabschnittes, der mit einer ungeraden Zeilennummer beginnt, verwendet werden?

Angenommen der Spaltenabschnitt wären die Zellen A3-A353, dann könnte man z.B. folgende Matrixformel verwenden:

=SUMME(WENN(REST(ZEILE(A3:A353);2)=1;A3:A353))

Welche Matrixformel könnte für die Berechnung jedes zweiten Wertes eines Spaltenabschnittes, der mit einer geraden Zeilennummer beginnt, verwendet werden?

Angenommen der Spaltenabschnitt wären die Zellen A2-A353, dann könnte man z.B. folgende Matrixformel verwenden:

=SUMME(WENN(REST(ZEILE(A2:A353);2)=0;A2:A353))

Welche Matrixformel könnte für die Berechnung jedes zweiten Wertes eines Zeilenabschnittes, der mit einer ungeraden Spaltennummer beginnt, verwendet werden?

Man beachte die Funktion SPALTE() liefert den Wert einer Spaltennummer, wobei die Spalte A den Wert 1, die Spalte B den Wert 2, die Spalte C den Wert 3, ... erhält.

Angenommen der Zeilenabschnitt wären die Zellen C2-L2, dann könnte man z.B. folgende Matrixformel verwenden:

=SUMME(WENN(REST(SPALTE(C2:L2);2)=1;C2:L2))

Welche Matrixformel könnte für die Berechnung jedes zweiten Wertes eines Zeilenabschnittes, der mit einer geraden Spaltennummer beginnt, verwendet werden?

Man beachte die Funktion SPALTE() liefert den Wert einer Spaltennummer, wobei die Spalte A den Wert 1, die Spalte B den Wert 2, die Spalte C den Wert 3, ... erhält.

Angenommen der Zeilenabschnitt wären die Zellen B2-L2, dann könnte man z.B. folgende Matrixformel verwenden:

=SUMME(WENN(REST(SPALTE(B2:L2);2)=0;B2:L2))

Anmerkungen:

  • Würde man den Teiler '2' in der Restermittlung durch eine ganze Zahl n>0 ersetzen, so würden die Beispiele je nach Verwendung jeden n-ten Wert einer Spalte bzw. einer Zeile addieren!

  • Auch Formeländerungen sind stets mit der Tastenkombination STRG+UMSCHALT+EINGABE abzuschließen!



Anzeige(n)

www. finitmat .de